Skip site navigation (1) Skip section navigation (2)

Section Navigation

FreeBSD 2.2.6 Errata Notes

The file 
ERRATA.TXT contains post-release ERRATA for 2.2.6 and should always
be considered the definitive place to look *first* before reporting
a problem with this release.  This file will also be periodically
updated as new issues are reported so even if you've checked this
file recently, check it again before filing a bug report.  Any
changes to this file are also automatically emailed to:

For 2.2.6 security advisories, see:

For the latest information.

---- Security Advisories:

Current active security advisories for 2.2.6:   4

for full information.

---- System Update Information:
o Root mountpoint change which affects those upgrading via
 "make world" or a FreeBSD 2.2.6 upgrade.

Fix:  2.2.6 introduces a change in the naming of the device from
      which the root filesystem is mounted.  This change affects all systems,
      however user intervention is only required for systems undergoing an
      upgrade installation.

Previously, the root filesystem was always mounted from the
compatibility slice, while other partitions on the same disk were
mounted from their true slice.  This might, for example, have resulted
in an /etc/fstab file like:

# Device      Mountpoint      FStype  Options         Dump    Pass#
/dev/wd0s2b   none            swap    sw              0       0
/dev/wd0a     /               ufs     rw              1       1
/dev/wd0s2f   /local0         ufs     rw              1       1
/dev/wd0s2e   /usr            ufs     rw              1       1

For FreeBSD 2.2.6 and later, this format changes so that the device for
'/' is consistent with others, ie.

# Device      Mountpoint      FStype  Options         Dump    Pass#
/dev/wd0s2b   none            swap    sw              0       0
/dev/wd0s2a   /               ufs     rw              1       1
/dev/wd0s2f   /local0         ufs     rw              1       1
/dev/wd0s2e   /usr            ufs     rw              1       1

If /etc/fstab is not updated manually in this case, the system will
issue a warning message whenever / is mounted (normally at startup)
indicating the change that must be made.  In addition, trouble may be
experienced if the root filesystem is not correctly unmounted, whereby
the root filesystem will not be marked clean at the next reboot.

This change should be made as soon as the upgraded system has been
successfully rebooted.

o The ppp program fails to work, citing a missing shared library
  called "".

Fix:  There are three possible fixes:

1. The easiest fix is to simply install the des distribution with
   /stand/sysinstall, remembering to pick a site that will allow you
   to export it if you're outside the United States and Canada
   ( and both fall into this

2. Purely as a work-around, and what you may need to do if ppp
   also constitutes your only way of getting to the net, is to simply
   do the following (as root):

      cp /usr/lib/ /usr/lib/
      ldconfig -m /usr/lib

3. Another fix, and one which doesn't involve having to fetch the DES
   bits, is to install the ppp sources in /usr/src/usr.sbin/ppp and rebuild
   them.  The sources are "smart" enough to know that the DES library isn't
   on the system and won't create a binary which depends on it.

NOTE:  If you choose the 2nd or 3rd fixes, you also will not be able to
use MSCHAP (Microsoft Win*) style authentication.

o The xterm program in XFree86 3.3.2 doesn't remove utmp entries on
  exit (e.g. xterm sessions show up in "who" or "w" even after they've

Fix:  Fetch the updated xterm binary at:

Or get the *latest* ports collection on your machine (see and use the port in x11/XFree86 to
build an xterm with this patch already applied (as of 98/04/06).
The patch itself can also be obtained from the port itself:

o The older Matsushita (Panasonic), Sony CDU-31 and Mitsumi (non-IDE)
  CDROM drives no longer permit CDROM installs.

Fix: Fetch an updated boot floppy from the updates/ directory, e.g.:

And use it to install 2.2.6 instead.  This problem is fixed in 2.2-stable
and will not be a problem with the next FreeBSD release.

Release Home