Skip site navigation (1) Skip section navigation (2)

FreeBSD Ports: Net-vpn

Search ports for:

Software related to virtual private networks

dsvpn-0.1.3
Dead Simple VPN
Long description | Changes | Main Web Site
Maintained by: egypcio@FreeBSD.org
Also listed in: Security, Net

fiked-0.0.5_7
Fake IKE PSK+XAUTH daemon based on VPNC
Long description | Changes | Main Web Site
Maintained by: ports@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, libgcrypt-1.8.5, libgpg-error-1.36, libnet-1.1.6_5,1
Also listed in: Security

govpn-7.5_1
Simple secure, DPI-resistant VPN daemon
Long description | Changes | Main Web Site
Maintained by: stargrave@stargrave.org
Requires: go-1.13.3,1, indexinfo-0.3.1
Also listed in: Security

mlvpn-2.3.1_2
Multi-link VPN
Long description | Changes | Main Web Site
Maintained by: olivier@FreeBSD.org
Requires: autoconf-2.69_3, autoconf-wrapper-20131203, automake-1.16.1_2, indexinfo-0.3.1, libev-4.24,1, libsodium-1.0.18, libtool-2.4.6_1, m4-1.4.18_1,1, perl5-5.30.0, pkgconf-1.6.3,1
Also listed in: Net

n2n-2.4
Layer Two Peer-to-peer VPN
Long description | Changes | Main Web Site
Maintained by: farrokhi@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1
Also listed in: Security, Net

ocserv-0.12.4_2
Server implementing the AnyConnect SSL VPN protocol
Long description | Changes | Main Web Site
Maintained by: cpm@FreeBSD.org
Requires: autoconf-2.69_3, autoconf-wrapper-20131203, automake-1.16.1_2, bash-5.0.11, ca_root_nss-3.47, gettext-runtime-0.20.1, gmp-6.1.2_1, gnutls-3.6.10, gperf-3.0.3_2, gsed-4.7, indexinfo-0.3.1, libev-4.24,1, libffi-3.2.1_3, libgcrypt-1.8.5, libgpg-error-1.36, libiconv-1.14_11, libidn2-2.2.0, libltdl-2.4.6, liblz4-1.9.2,1, libpcl-1.12, libtasn1-4.14, libtool-2.4.6_1, libunistring-0.9.10_1, libxml2-2.9.9, libxslt-1.1.33, m4-1.4.18_1,1, nettle-3.5.1_1, nspr-4.23, nss-3.47, oath-toolkit-2.6.2, p11-kit-0.23.18.1, perl5-5.30.0, pkgconf-1.6.3,1, protobuf-3.9.2,1, protobuf-c-1.3.2_3, python36-3.6.9, readline-8.0.0, sqlite3-3.29.0_1, talloc-2.2.0, tpm-emulator-0.7.4_2, trousers-0.3.14_2, xmlsec1-1.2.25
Also listed in: Net, Security

openconnect-8.03
Client for Cisco's AnyConnect SSL VPN
Long description | Changes | Main Web Site
Maintained by: zi@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, libffi-3.2.1_3, libxml2-2.9.9, pkgconf-1.6.3,1, python36-3.6.9, readline-8.0.0, vpnc-scripts-20190611
Also listed in: Security

openconnect-gui-1.4.1_3
Graphical OpenConnect client
Long description | Changes | Main Web Site
Maintained by: pkubaj@anongoth.pl
Requires: ca_root_nss-3.47, cmake-3.15.4, curl-7.66.0, dbus-1.12.12, etc_os-release-0.1_2, expat-2.2.8, fontconfig-2.12.6,1, freetype2-2.10.1, gettext-runtime-0.20.1, glib-2.56.3_6,1, gmp-6.1.2_1, gnutls-3.6.10, graphite2-1.3.13_1, harfbuzz-2.6.2, hicolor-icon-theme-0.17, icu-65.1,1, indexinfo-0.3.1, jpeg-turbo-2.0.3, jsoncpp-1.8.1_7, libICE-1.0.10,1, libSM-1.2.3,1, libX11-1.6.8,1, libXau-1.0.9, libXdamage-1.1.5, libXdmcp-1.1.3, libXext-1.3.4,1, libXfixes-5.0.3_2, libXi-1.7.10,1, libXmu-1.1.3,1, libXrender-0.9.10_2, libXt-1.2.0,1, libXxf86vm-1.1.4_3, libarchive-3.4.0,1, libdrm-2.4.99,1, libepoll-shim-0.0.20190311, libevdev-1.5.9, libffi-3.2.1_3, libgudev-230_1, libiconv-1.14_11, libidn2-2.2.0, libinput-1.12.6_1, liblz4-1.9.2,1, libmtdev-1.1.5_2, libnghttp2-1.39.2, libpciaccess-0.16, libpthread-stubs-0.4, libtasn1-4.14, libudev-devd-0.4, libunistring-0.9.10_1, libunwind-20170615, libuv-1.33.0, libwacom-0.32, libxcb-1.13.1, libxkbcommon-0.8.4, libxml2-2.9.9, libxshmfence-1.3, lzo2-2.10_1, mesa-libs-18.3.2_2, nettle-3.5.1_1, ninja-1.9.0,2, openconnect-8.03, p11-kit-0.23.18.1, pciids-20190725, pcre-8.43_2, pcre2-10.33, perl5-5.30.0, pkgconf-1.6.3,1, png-1.6.37, py36-evdev-0.8.1, py36-pyudev-0.21.0, py36-six-1.12.0, py37-setuptools-41.2.0, python36-3.6.9, python37-3.7.5, qt5-buildtools-5.13.0_1, qt5-concurrent-5.13.0_1, qt5-core-5.13.0_1, qt5-dbus-5.13.0_1, qt5-gui-5.13.0_2, qt5-network-5.13.0_1, qt5-qmake-5.13.0, qt5-widgets-5.13.0_1, qtchooser-66, readline-8.0.0, rhash-1.3.5, tpm-emulator-0.7.4_2, trousers-0.3.14_2, vpnc-scripts-20190611, wayland-1.16.0_1, xcb-util-0.4.0_2,1, xcb-util-image-0.4.0_1, xcb-util-keysyms-0.4.0_1, xcb-util-renderutil-0.3.9_1, xcb-util-wm-0.4.1_3, xdg-utils-1.1.3_1, xkeyboard-config-2.27, xorgproto-2019.1, xprop-1.2.4, xset-1.2.4_3
Also listed in: Security

openfortivpn-1.10.0
Client for PPP+SSL VPN tunnel services
Long description | Changes | Main Web Site
Maintained by: lifanov@FreeBSD.org
Requires: autoconf-2.69_3, autoconf-wrapper-20131203, automake-1.16.1_2, indexinfo-0.3.1, m4-1.4.18_1,1, perl5-5.30.0, pkgconf-1.6.3,1
Also listed in: Security

openvpn-2.4.7
Secure IP/Ethernet tunnel daemon
Long description | Changes | Main Web Site
Maintained by: mandree@FreeBSD.org
Requires: easy-rsa-3.0.6, liblz4-1.9.2,1, lzo2-2.10_1, pkgconf-1.6.3,1
Also listed in: Security, Net

openvpn-admin-1.9.4_6
GUI frontend to openvpn
Long description | Changes | Main Web Site
Maintained by: egypcio@FreeBSD.org
Requires: atk-2.28.1, avahi-app-0.7_2, ca_root_nss-3.47, cairo-1.16.0,2, cups-2.2.12, dbus-1.12.12, dbus-glib-0.110, dejavu-2.37_1, easy-rsa-3.0.6, encodings-1.0.5,1, expat-2.2.8, font-bh-ttf-1.0.3_4, font-misc-ethiopic-1.0.3_4, font-misc-meltho-1.0.3_4, fontconfig-2.12.6,1, freetype2-2.10.1, fribidi-0.19.7, gdbm-1.18.1_1, gdk-pixbuf2-2.38.1, gettext-runtime-0.20.1, gettext-tools-0.20.1_1, giflib-5.1.9, glib-2.56.3_6,1, gmake-4.2.1_3, gmp-6.1.2_1, gnome_subr-1.0, gnutls-3.6.10, gobject-introspection-1.56.1,1, graphite2-1.3.13_1, gtk-sharp20-2.12.45_1, gtk-update-icon-cache-2.24.32, gtk2-2.24.32, harfbuzz-2.6.2, hicolor-icon-theme-0.17, indexinfo-0.3.1, intltool-0.51.0_1, jbigkit-2.1_1, jpeg-turbo-2.0.3, lcms2-2.9, libICE-1.0.10,1, libSM-1.2.3,1, libX11-1.6.8,1, libXScrnSaver-1.2.3_2, libXau-1.0.9, libXcomposite-0.4.5,1, libXcursor-1.2.0, libXdamage-1.1.5, libXdmcp-1.1.3, libXext-1.3.4,1, libXfixes-5.0.3_2, libXft-2.3.2_3, libXi-1.7.10,1, libXinerama-1.1.4_2,1, libXrandr-1.5.2, libXrender-0.9.10_2, libXxf86vm-1.1.4_3, libdaemon-0.14_1, libdrm-2.4.99,1, libepoll-shim-0.0.20190311, libffi-3.2.1_3, libfontenc-1.1.4, libglade2-2.6.4_9, libiconv-1.14_11, libidn2-2.2.0, libinotify-20180201_1, liblz4-1.9.2,1, libpaper-1.1.24.4, libpciaccess-0.16, libpthread-stubs-0.4, libtasn1-4.14, libtextstyle-0.20.1, libunistring-0.9.10_1, libunwind-20170615, libxcb-1.13.1, libxml2-2.9.9, libxshmfence-1.3, lzo2-2.10_1, mesa-libs-18.3.2_2, mkfontscale-1.2.1, mono-5.10.1.57_2, nettle-3.5.1_1, openjpeg-2.3.1, openvpn-2.4.7, p11-kit-0.23.18.1, p5-XML-LibXML-2.0134,1, p5-XML-NamespaceSupport-1.12, p5-XML-Parser-2.44, p5-XML-SAX-1.02, p5-XML-SAX-Base-1.09, pango-1.42.4_3, pciids-20190725, pcre-8.43_2, perl5-5.30.0, pixman-0.38.4, pkgconf-1.6.3,1, png-1.6.37, py27-olefile-0.46, py27-pillow-6.2.0, py36-tkinter-3.6.9_6, py37-setuptools-41.2.0, python27-2.7.16_1, python36-3.6.9, python37-3.7.5, readline-8.0.0, shared-mime-info-1.10_1, tcl86-8.6.9_1, tiff-4.0.10_1, tk86-8.6.9_1, tpm-emulator-0.7.4_2, trousers-0.3.14_2, wayland-1.16.0_1, webp-1.0.3_1, xmlcatmgr-2.2_2, xorg-fonts-truetype-7.7_1, xorgproto-2019.1
Also listed in: Security, Gnome

openvpn-auth-ldap-2.0.4.0.s1379_3
LDAP authentication plugin for OpenVPN
Long description | Changes | Main Web Site
Maintained by: mandree@FreeBSD.org
Requires: autoconf-2.69_3, autoconf-wrapper-20131203, automake-1.16.1_2, check-0.12.0_1, easy-rsa-3.0.6, indexinfo-0.3.1, liblz4-1.9.2,1, libobjc2-2.0_1, lzo2-2.10_1, m4-1.4.18_1,1, openldap-client-2.4.48, openvpn-2.4.7, perl5-5.30.0, re2c-0.14.3
Also listed in: Security

openvpn-auth-radius-2.1_4
RADIUS authentication plugin for OpenVPN
Long description | Changes | Main Web Site
Maintained by: m.tsatsenko@gmail.com
Requires: easy-rsa-3.0.6, gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, libgcrypt-1.8.5, libgpg-error-1.36, liblz4-1.9.2,1, lzo2-2.10_1, openvpn-2.4.7
Also listed in: Security

openvpn-auth-script-1.0.0.3
Generic script-based deferred auth plugin for OpenVPN
Long description | Changes | Main Web Site
Maintained by: pdemon@gmail.com
Requires: easy-rsa-3.0.6, gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, liblz4-1.9.2,1, lzo2-2.10_1, openvpn-2.4.7
Also listed in: Security, Net

openvpn-devel-201935
Secure IP/Ethernet tunnel daemon
Long description | Changes | Main Web Site
Maintained by: ecrist@secure-computing.net
Requires: easy-rsa-3.0.6, liblz4-1.9.2,1, lzo2-2.10_1, pkgconf-1.6.3,1
Also listed in: Security, Net

openvpn-mbedtls-2.4.7
Secure IP/Ethernet tunnel daemon, mbedTLS-based build
Long description | Changes | Main Web Site
Maintained by: mandree@FreeBSD.org
Requires: easy-rsa-3.0.6, liblz4-1.9.2,1, lzo2-2.10_1, mbedtls-2.16.3, pkgconf-1.6.3,1
Also listed in: Security, Net

poptop-1.4.0_1
Windows 9x compatible PPTP (VPN) server
Long description | Changes | Main Web Site
Maintained by: ports@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1
Also listed in: Net

pptpclient-1.10.0
PPTP client for establishing a VPN link with an NT server
Long description | Changes | Main Web Site
Maintained by: sunpoet@FreeBSD.org
Requires: perl5-5.30.0
Also listed in: Net

protonvpn-cli-1.1.2_1
ProtonVPN Command line tool
Long description | Changes | Main Web Site
Maintained by: phascolarctos@protonmail.ch
Requires: bash-5.0.11, ca_root_nss-3.47, easy-rsa-3.0.6, gettext-runtime-0.20.1, indexinfo-0.3.1, libffi-3.2.1_3, libidn2-2.2.0, liblz4-1.9.2,1, libunistring-0.9.10_1, lzo2-2.10_1, openvpn-2.4.7, python36-3.6.9, readline-8.0.0, wget-1.20.3
Also listed in: Security, Net

py27-sshuttle-0.78.5
Full-featured VPN over an SSH tunnel
Long description | Changes | Main Web Site
Maintained by: koobs@FreeBSD.org
Requires: gettext-runtime-0.20.1, indexinfo-0.3.1, libffi-3.2.1_3, py27-setuptools_scm-3.3.3, py37-setuptools-41.2.0, python27-2.7.16_1, python37-3.7.5, readline-8.0.0
Also listed in: Net, Python

py36-sshuttle-0.78.5
Full-featured VPN over an SSH tunnel
Long description | Changes | Main Web Site
Maintained by: koobs@FreeBSD.org
Requires: gettext-runtime-0.20.1, indexinfo-0.3.1, libffi-3.2.1_3, py27-setuptools_scm-3.3.3, py37-setuptools-41.2.0, python27-2.7.16_1, python36-3.6.9, python37-3.7.5, readline-8.0.0
Also listed in: Net, Python

softether-4.29.9680_4
SoftEther VPN 4 (RTM version)
Long description | Changes | Main Web Site
Maintained by: meta@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, libiconv-1.14_11, readline-8.0.0
Also listed in: Security

softether-devel-4.30.9700.b_1
Softether VPN 4 (stable beta version)
Long description | Changes | Main Web Site
Maintained by: meta@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, libiconv-1.14_11, readline-8.0.0
Also listed in: Security

softether5-5.01.9671_1
SoftEther VPN 5 (Developer Edition)
Long description | Changes | Main Web Site
Maintained by: meta@FreeBSD.org
Requires: ca_root_nss-3.47, cmake-3.15.4, cpu_features-0.4.0, curl-7.66.0, expat-2.2.8, indexinfo-0.3.1, jsoncpp-1.8.1_7, libarchive-3.4.0,1, libiconv-1.14_11, liblz4-1.9.2,1, libnghttp2-1.39.2, libuv-1.33.0, lzo2-2.10_1, readline-8.0.0, rhash-1.3.5
Also listed in: Security

strongswan-5.8.1
Open Source IKEv2 IPsec-based VPN solution
Long description | Changes | Main Web Site
Maintained by: strongswan@nanoteq.com
Requires: ca_root_nss-3.47, curl-7.66.0, libnghttp2-1.39.2, pkgconf-1.6.3,1
Also listed in: Security

tinc-1.0.36
Virtual Private Network (VPN) daemon
Long description | Changes | Main Web Site
Maintained by: dinoex@FreeBSD.org
Requires: gettext-runtime-0.20.1, indexinfo-0.3.1, libiconv-1.14_11, lzo2-2.10_1, p5-Locale-libintl-1.31, p5-Text-Unidecode-1.30, p5-Unicode-EastAsianWidth-12.0, perl5-5.30.0, texinfo-6.6_4,1
Also listed in: Security

tinc-devel-1.1pre17_3
Virtual Private Network (VPN) daemon
Long description | Changes | Main Web Site
Maintained by: dinoex@FreeBSD.org
Requires: gettext-runtime-0.20.1, indexinfo-0.3.1, libiconv-1.14_11, lzo2-2.10_1, p5-Locale-libintl-1.31, p5-Text-Unidecode-1.30, p5-Unicode-EastAsianWidth-12.0, perl5-5.30.0, readline-8.0.0, texinfo-6.6_4,1
Also listed in: Security

vpnc-0.5.3_13
Client for Cisco 3000 VPN Concentrator
Long description | Changes | Main Web Site
Maintained by: ports@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, libgcrypt-1.8.5, libgpg-error-1.36, perl5-5.30.0, vpnc-scripts-20190611
Also listed in: Security

vpnc-scripts-20190611
Collection of scripts to setup routes and other changes for a VPN
Long description | Changes | Main Web Site
Maintained by: zi@FreeBSD.org
Also listed in: Sysutils

wireguard-0.0.20191012
Fast, modern and secure VPN Tunnel
Long description | Changes | Main Web Site
Maintained by: decke@FreeBSD.org
Requires: bash-5.0.11, gettext-runtime-0.20.1, gmake-4.2.1_3, indexinfo-0.3.1, wireguard-go-0.0.20191012
Also listed in: Net

wireguard-go-0.0.20191012
WireGuard implementation in Go
Long description | Changes | Main Web Site
Maintained by: decke@FreeBSD.org
Requires: gettext-runtime-0.20.1, gmake-4.2.1_3, go-1.13.3,1, indexinfo-0.3.1
Also listed in: Net

top -- Index