Skip site navigation (1) Skip section navigation (2)

Ports and Packages for Supported Releases

Support of FreeBSD releases by ports and the ports infrastructure matches the policies set out by the FreeBSD Security Officer. Once a major branch X reaches its EOL date, the "last known good" ports tree will be tagged with the RELEASE_X_EOL tag as a convenience to those remaining users who intend to self-support their installations. This tag is not supported in any way and security fixes will not be applied. Usage is therefore highly discouraged and should only be used as a last resort.

For all supported major src branches, all ports will be included in an automated quality assurance procedure which will build, install, package, and deinstall each port on all Tier 1 platforms. Maintainers and committers are notified of failures detected during testing. Ports that are known not to build or run on a given supported branch or platform will be marked as such.

Prebuilt binary packages will also be provided for all major branches and Tier 1 platforms and will be made available via anonymous FTP from a worldwide set of mirror sites. Package builds will use the oldest supported minor release within each major branch to ensure ABI and KBI backwards compatibility within each major branch, and support all minor versions of each major branch, including -RELEASE and -STABLE.

The current package sets and estimated lifetimes of the currently supported branches are given below. The Estimated EoL (end-of-life) column gives the earliest date on which that branch is likely to be dropped.

Branch Release Package Branch Package Set Estimated EoL
RELENG_8 n/a RELENG_8_3 packages-8-stable last release + 2 years
RELENG_8_4 8.4-RELEASE RELENG_8_4 packages-8-stable June 30, 2015
RELENG_9 n/a RELENG_9_1 packages-9-stable last release + 2 years
RELENG_9_1 9.1-RELEASE RELENG_9_1 packages-9-stable December 31, 2014
HEAD n/a HEAD packages-10-current Best Effort

Older releases are not maintained, ports and packages may not be able to install or run. Users are strongly encouraged to upgrade to one of the supported releases mentioned above.