6.25. Using Databases

Table 6.35. Variables for Ports Using Databases
VariableMeans
USE_BDBIf variable is set to yes, add dependency on databases/db41 port. The variable may also be set to values: 40, 41, 42, 43, 44, 46, 47, 48, or 51. You can declare a range of acceptable values, USE_BDB=42+ will find the highest installed version, and fall back to 42 if nothing else is installed.
USE_MYSQLIf the variable is set to yes, add a dependency on the databases/mysql55-client port. An associated variable, WANT_MYSQL_VER, may be set to values such as 323, 40, 41, 50, 51, 52, 55, or 60.
USE_PGSQLIf set to yes, add dependency on databases/postgresql90-client port. An associated variable, WANT_PGSQL_VER, may be set to values such as 83, 84, 90, 91 or 92. You can declare a minimum or maximum value; WANT_PGSQL_VER= 90+ will cause the port to depend on a minimum version of 9.0.
USE_SQLITEIf variable is set to yes, add dependency on databases/sqlite3 port. The variable may also be set to values: 3, 2.

More details are available in bsd.database.mk.

All FreeBSD documents are available for download at http://ftp.FreeBSD.org/pub/FreeBSD/doc/

Questions that are not answered by the documentation may be sent to <freebsd-questions@FreeBSD.org>.
Send questions about this document to <freebsd-doc@FreeBSD.org>.